hi, i'm Chantelle
You know what’s annoying? Completing your first Android app (almost), have it running on an actual device and everything.. only to rebuild and debug it to find it suddenly won’t work any more. Why? I have no idea. I only tried to debug it on a virtual device emulator! Nothing I seem to do now works.  I get this error:

 Android Launch!adb is running normally.Performing com.chantelle.snake activity launchAutomatic Target Mode: Preferred AVD ‘AVD’ is not available. Launching new emulator.Launching a new emulator with Virtual Device ‘AVD’ emulator: warning: opening audio input failed

Then I sit and wait for 500 hours for the apk to install on my AVD, but NOOOOOO. NOTHING!! And I have Google’d the hell out of it! Seems like lots of people have been getting this error. But nobody seems to know why or how to fix it! And the solutions they have suggested have made no impact whatsoever. And my apk file seems to have jumped to about 50MB. Yeah.. that’s not right. So it’s half 1 in the morning and I’ve uninstalled everything Android and Eclipse related on my computer, only to spend the next 60 billion years waiting for the Android SDK’s to install again. D: I’m not expecting it to work. I’m going to try and move the code into a new project and hope for the best. If it doesn’t work I’m officially giving up and becoming a hairdresser. So whilst my fate hangs in the balance I’m going to play Solitaire and listen to Kelly Clarkson.

You know what’s annoying? Completing your first Android app (almost), have it running on an actual device and everything.. only to rebuild and debug it to find it suddenly won’t work any more. Why? I have no idea. I only tried to debug it on a virtual device emulator! Nothing I seem to do now works.  I get this error:

 Android Launch!
adb is running normally.
Performing com.chantelle.snake activity launch
Automatic Target Mode: Preferred AVD ‘AVD’ is not available. Launching new emulator.
Launching a new emulator with Virtual Device ‘AVD’
emulator: warning: opening audio input failed

Then I sit and wait for 500 hours for the apk to install on my AVD, but NOOOOOO. NOTHING!! And I have Google’d the hell out of it! Seems like lots of people have been getting this error. But nobody seems to know why or how to fix it! And the solutions they have suggested have made no impact whatsoever. And my apk file seems to have jumped to about 50MB. Yeah.. that’s not right. So it’s half 1 in the morning and I’ve uninstalled everything Android and Eclipse related on my computer, only to spend the next 60 billion years waiting for the Android SDK’s to install again. D: I’m not expecting it to work. I’m going to try and move the code into a new project and hope for the best. If it doesn’t work I’m officially giving up and becoming a hairdresser. So whilst my fate hangs in the balance I’m going to play Solitaire and listen to Kelly Clarkson.

26 notes
  1. darthtelle posted this